MikroTik: автоматическое обновление CAP’s в CAPsMAN

MikroTik CAPsMAN

Вот и дождался я выхода новой версии RouterOS после настройки у себя CAPsMAN что бы проверить работу автоматического обновления CAP’s.

Освоить MikroTik Вы можете с помощью онлайн-куса «Настройка оборудования MikroTik». Курс содержит все темы, которые изучаются на официальном курсе MTCNA. Автор курса – официальный тренер MikroTik. Подходит и тем, кто уже давно работает с микротиками, и тем, кто еще их не держал в руках. В курс входит 162 видеоурока, 45 лабораторных работ, вопросы для самопроверки и конспект.

Предварительная подготовка

Подопытные: CAPsMAN – RB760iGS (hEX S), CAP – RBcAPGi-5acD2nD (cAP ac) и RBD52G-5HacD2HnD-TC (hAP ac²)

CAPsMAN и CAP’s настроены как написано в “MikroTik: настройка домашней и гостевой Wi-Fi сетей с использованием CAPsMAN без VLAN

На момент перед началом настроек на CAPsMAN версия RouterOS 6.45.5, на CAP 6.45.3. cAP ac включен, hAP ac^2 выключен.

На CAPsMAN примонтирована флешка /disk и на ней создана папка updates, в папку помещена прошивка routeros-arm-6.45.5.npk.

CAPsMAN файлы
CAPsMAN файлы

Настройка автоматического обновления CAP’s

В настройках CAPsMANManager указываем путь где будут лежать обновления и выбираем Upgrade Policy.

Здесь три варианта:

  • none – не требовать обновления
  • require same version – требовать обязательное обновление до версии установленной на CAPsMAN, если CAP не обновить то он работать не будет
  • suggest same version – предложить обновиться до версии RouterOS установленной на CAPsMAN, если не обновиться то CAP продолжит работу на старой версии

Выберем последний вариант

Настройка CAPs Manager
Настройка CAPs Manager
/caps-man manager set package-path=/disk/updates upgrade-policy=suggest-same-version

Как только нажали Apply включенная точка сразу начала обновляться и ушла в перезагрузку. После загрузки видим обновлённую версию RouterOS на CAP.

Обновление CAPs
Обновление CAPs

Проверяем обновление на вновь подключаемой точке

Теперь включим выключенный hAP ac^2

При включении новая точка так же обновилась без проблем, о чём нам рапортует лог-файл на CAPsMAN

CAPsMAN Log
CAPsMAN Log

А вот с обновление firmware не всё так радужно, ни в первом ни во втором случае firmware не обновилось

MikroTik - Обновление firmware
MikroTik – Обновление firmware

Автоматическое обновление firmware

Для автоматического обновления firmware в планировщике на CAPs создадим следующее событие:

Автоматическое обновление firmware
Автоматическое обновление firmware routerboard
/system scheduler
add name=AutoUpgradeFirmware on-event="if ([/system routerboard get current-firmware] != [/system routerboard get upgrade-firmware]) do={\r\
    \n/system routerboard upgrade\r\
    \n:delay 15s\r\
    \n/system reboot\r\
    \n}\r\
    \n" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive start-time=startup

Данный скрипт после загрузки маршрутизатора сверяет версии current и upgrade firmware и в случае их несовпадения запускает upgrade с последующей перезагрузкой.

Если такой скрипт разместить в корне каждого CAPs например под именем upgradefirmware.auto.rsc то он выполнится автоматически, но как автоматизировать его рассылку на все CAP’s, особенно если они без IP, я ещё не придумал.

Если у Вас есть решение то поделитесь им пожалуйста в комментариях.

08.02.2020 Изменил скрипт обновления firmware, плюс поменял его запуск, теперь вместо запуска по расписанию он выполняется сразу после запуска маршрутизатора. (Спасибо PaulS за подсказку в комментариях)

Освоить MikroTik Вы можете с помощью онлайн-куса «Настройка оборудования MikroTik». Курс содержит все темы, которые изучаются на официальном курсе MTCNA. Автор курса – официальный тренер MikroTik. Подходит и тем, кто уже давно работает с микротиками, и тем, кто еще их не держал в руках. В курс входит 162 видеоурока, 45 лабораторных работ, вопросы для самопроверки и конспект.

Оцените данную запись
 [Всего голосов: 5 - Общая оценка: 5]

MikroTik: автоматическое обновление CAP’s в CAPsMAN: 4 комментария

  1. PaulS

    а как (какими командами) создать папку update на флэшке?

    1. Юрий Грибов Автор записи

      Из командной строки никак. Не знаю с чем связано такое ограничение в RouterOS, но оно есть.
      Проще всего это сделать средствами winbox скопировав на флэшку папку.

  2. PaulS

    Ну да, так и понял… только у меня из update обновление почему-то не запустилось… Мне показалось удобнее поправить путь в менеджере к корню диска, куда по умолчанию скачивается новый апдейт.
    А так как после обновления система перезагружается, может скрипт запускать после старта системы?

    1. Юрий Грибов Автор записи

      Действительно, запускать скрипт после старта системы наверное будет более правильно, мне что то не пришло это в голову, по привычке в шедулер запихнул ))

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *