MikroTik: Cube 60G ac – настройка wireless bridge с автоматическим переключением на резервный канал

Cube 60G ac
Cube 60G ac – configure automatic fail-over (bonding) 5Ghz link in combination with 60Ghz devices

Подопытные: CubeG-5ac60ad в количестве двух экземпляров. Расстояние между объектами около 75 метров.

Собственно те, кто покупал данные точки спаренным набором Wireless Wire Cube (CubeG-5ac60adpair), скорее всего ничего нового для себя не откроют, настройка будет почти полностью повторять дефолтную. Ну а так как я покупал их по раздельности, то приведу их пошаговую настройку с небольшими изменениями.

Настройку пользователя(ей), паролей и всего прочего опустим, начнём непосредственно с настройки моста.

Так как у данных устройств лицензия L3, то одна из точек будет настраиваться не как ap bridge, а как bridge. Вторая соответственно как station bridge.

Перед употреблением девайсы очень желательно “отнетинсталить“, иначе они залочены на регион russia3.

На обеих точках добавляем бридж:

/interface bridge
add name=bridge

Настройка 60Ghz wireless connection

На bridge:

/interface w60g
set [ find ] disabled=no frequency=auto isolate-stations=yes mode=bridge \
    name=wlan60-1 password=PASSWORD_FOR_60GHZ_CONNECTION put-stations-in-bridge=bridge \
    ssid=SSID-60GHZ
/interface w60g station
add name=wlan60-station-1 parent=wlan60-1 \
    remote-address=DE:AD:C0:DE:CA:FE

Здесь remote-address это MAC адрес 60Ghz интерфейса второй точки, которая station bridge.

На station bridge просто конфигурируем w60g интерфейс:

/interface w60g
set [ find ] disabled=no frequency=auto mode=station-bridge \
    name=wlan60-1 password=PASSWORD_FOR_60GHZ_CONNECTION ssid=SSID-60GHZ

Настройка 5Ghz канала

Настройка 5Ghz канала самая обычная. В приведённой конфигурации всё на автомате, в реальности с частотами и протоколами нужно играться на месте.

На bridge:

/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa2-psk disable-pmkid=yes eap-methods="" \
    management-protection=required management-protection-key=PASSWORD \
    mode=dynamic-keys name=SEC-PROFILE-NAME supplicant-identity="" wpa2-pre-shared-key=\
    PASSWORD_FOR_5GHZ
/interface wireless
set [ find default-name=wlan1 ] adaptive-noise-immunity=ap-and-client-mode \
    band=5ghz-onlyac channel-width=20/40/80mhz-XXXX country=russia4 disabled=\
    no frequency=auto hw-protection-mode=rts-cts installation=outdoor mode=\
    bridge multicast-helper=full nv2-preshared-key=PASSWORD_FOR_5GHZ_NV \
    nv2-security=enabled security-profile=SEC-PROFILE-NAME ssid=SSID-5GHZ \
    tdma-period-size=auto wireless-protocol=any wmm-support=enabled \
    wps-mode=disabled
/interface wireless nstreme
set wlan1 enable-nstreme=yes

На station bridge:

/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa2-psk disable-pmkid=yes eap-methods="" \
    management-protection=required management-protection-key=PASSWORD \
    mode=dynamic-keys name=SEC-PROFILE-NAME supplicant-identity="" wpa2-pre-shared-key=\
    PASSWORD_FOR_5GHZ
/interface wireless
set [ find default-name=wlan1 ] adaptive-noise-immunity=client-mode band=\
    5ghz-a/n/ac channel-width=20/40/80mhz-XXXX country=russia4 disabled=no \
    frequency=auto hw-protection-mode=rts-cts installation=outdoor mode=\
    station-bridge multicast-helper=full nv2-preshared-key=PASSWORD_FOR_5GHZ_NV \
    nv2-security=enabled security-profile=SEC-PROFILE-NAME ssid=SSID-5GHZ \
    station-roaming=enabled wireless-protocol=any wmm-support=\
    enabled
/interface wireless nstreme
set wlan1 enable-nstreme=yes

Настраиваем bonding и добавим интерфейсы в bridge

В отличии от дефолтной конфигурации Link Monitoring в bonding интерфейсе я установил arp, а не mii, т.к. слабо себе представляю физическое падение wireless интерфейса, а вот недоступность из-за погодных условий это да.

На bridge:

/interface bonding
add arp-interval=50ms arp-ip-targets=ip-address-station-bridge link-monitoring=arp mode=\
    active-backup name=bonding1 primary=wlan60-station-1 slaves=\
    wlan60-station-1,wlan1
/interface bridge port
add bridge=bridge interface=ether1
add bridge=bridge interface=bonding1

На station bridge:

/interface bonding
add arp-interval=50ms arp-ip-targets=ip-address-bridge link-monitoring=arp mode=\
    active-backup name=bonding1 primary=wlan60-1 slaves=wlan60-1,wlan1
/interface bridge port
add bridge=bridge interface=ether1
add bridge=bridge interface=bonding1

Собственно на этом всё. Точки юстировал на глазок, расстояние небольшое да и на улице было ветрено и холодно что бы сидеть там с ноутбуком )) Что получилось на скрине ниже, на мой взгяд на этот раз “глазок” меня не сильно подвёл ))

P.S. После установки у нас ещё не было большого снегопада, так что я не могу сейчас сказать как на самом деле поведёт себя канал и будет ли переключаться на 5 Ghz.

Есть ещё мысль попробовать настроить fail-over не через bonding, а по STP, но это чуть позже.

Всех со СТАРЫМ НОВЫМ ГОДОМ!

Оцените данную запись
 [Всего голосов: 0 - Общая оценка: 0]

Добавить комментарий

Ваш адрес email не будет опубликован.