MikroTik CHR: установка на Google Cloud Platform / Compute Engine

Недавно Google запустил “аукцион невиданной щедрости”, начав предоставлять триальный доступ на 12 месяцев к своей облачной платформе + 300$ на использование их сервисов. Ну а так как я как раз неспешно подыскивал VDS-хостинг для установки MikroTik CHR, то просто не смог пройти мимо такого предложения.

Освоить MikroTik Вы можете с помощью онлайн-куса «Настройка оборудования MikroTik». Курс содержит все темы, которые изучаются на официальном курсе MTCNA. Автор курса – официальный тренер MikroTik. Подходит и тем, кто уже давно работает с микротиками, и тем, кто еще их не держал в руках. В курс входит 162 видеоурока, 45 лабораторных работ, вопросы для самопроверки и конспект.

Подготовка образа RouterOS

Начать установку следует с подготовки образа RouterOS для установки в Compute Engine. Нужно скачать актуальную версию RouterOS и изменить размер образа, так как Google поддерживает образы дисков с шагом в 1GB.

mkdir chr
cd chr
wget https://download.mikrotik.com/routeros/6.44.6/chr-6.44.6.img.zip
unzip chr-6.44.6.img.zip
truncate --size=1G chr-6.44.6.img
mv chr-6.44.6.img disk.raw
tar -Sczf chr-6.44.6.img.tar.gz disk.raw

Далее в браузере в Google Cloud Platform создадим новый проект и назовём его к примеру MikroTik-CHR

Затем в нашем проекте заходим “Хранение данных – Storage – Обзор” и создаём там сегмент с уникальным именем (все названия как есть на русском языке из гугловской панели), место хранения выбираем Multi-region, класс хранилища Coldline и копируем сюда наш подготовленный образ RouterOS.

На этом подготовку к установке можно считать законченной.

Установка MikroTik CHR в облако Google

Теперь займёмся непосредственно установкой.

Перейдём в панели “Ресурсы – Compute Engine – Экземпляры ВМ” и нажимаем там на + (создать экземпляр)

Дадим название нашей ВМ, выберем регион где она будет установлена, тип машины (количество ЦП и ОЗУ) и в качестве загрузочного диска выберем наш образ.

Нажимаем кнопку создать и на этом собственно всё, наша виртуальная машина с RouterOS на борту создана. Осталось её немного настроить.

Настройки VM

Настройки сети

Переходим в панели “Сеть VPC – Внешние IP-адреса” и резервируем там для нашего маршрутизатора статический IP (нам ведь не нужен динамический IP на роутере?)

Статик IP
Статик IP

Далее заходим в “Правила брандмауэра”, включаем доступ по 22 порту и быстро-быстро подключаемся на наш MikroTik по ssh и меняем пароль пользователю admin ))

/user set admin password=bla-bla
MikroTik CHR: установка на Google Cloud Platform / Compute Engine
Правила firewall

В принципе какими то простыми правилами можно рулить и отсюда, или можно полностью открыть все порты и протоколы и файерволлом рулить уже непосредственно на RouterOS.

По рекомендации Google меняем размер MTU

/interface ethernet
set [ find default-name=ether1 ] disable-running-check=no mtu=1460

На этом всё! ))

Освоить MikroTik Вы можете с помощью онлайн-куса «Настройка оборудования MikroTik». Курс содержит все темы, которые изучаются на официальном курсе MTCNA. Автор курса – официальный тренер MikroTik. Подходит и тем, кто уже давно работает с микротиками, и тем, кто еще их не держал в руках. В курс входит 162 видеоурока, 45 лабораторных работ, вопросы для самопроверки и конспект.

Оцените данную запись
 [Всего голосов: 1 - Общая оценка: 5]

MikroTik CHR: установка на Google Cloud Platform / Compute Engine: 8 комментариев

  1. Виталий Савосин

    Доброго дня!
    К сожалению, статья не полная. Вы пропустили момент создания image из образа raw-disk.
    Что очевидно даже на скрине, так как версия на скрине монтирования boot disk в момент создания машины не соответствует версии, которую вы вначале преобразовываете.

    1. Юрий Грибов Автор записи

      Честно говоря не совсем понял что пропустил. Ещё раз перечитал что сам написал и всё равно не понял ))
      По поводу несоответствия версий не буду спорить, такое у меня в записях сплошь и рядом. Всё дело в том, что скрины я делаю во время установки по живому и когда начинаю готовить запись к публикации, понимаю что что либо “недоскринил” )) Тогда я могу просто залезть в панель управления и “доскринить” пропущенное. С момента когда делал первую партию скринов до момента когда сделал недостающие может пройти какое то время и за это время что-то мог слегка изменить в конфигурации или обновить версию.
      Просто так как пишу сам, а не переписываю у других, то такие мелкие нестыковки иногда случаются, ничего страшного в этом не вижу.
      И кстати image из raw создаётся вот этой командой:
      tar -Sczf chr-6.44.6.img.tar.gz disk.raw
      об этом написано и это я не забыл ))

  2. ERBIEV RUSTAM

    Весь день убил делая по этому мануалу, и уперевшись в то что google в упор не хотел видеть созданный и загруженный образ помогло это
    https: //www.modalsemangat.com/2018/08/install-mikrotik-chr-google-cloud.html

    1. Юрий Грибов Автор записи

      А в чём разница с тем что написано у меня? Всё тоже самое.

      1. Александр

        Разница в том, что там описан момент с созданием Image(образа), а вы его пропустили. Если просто добавить Storage, то при создании виртуальной машины оно ругается что ваш сторадж ниразу не image и не создаёт виртуалку. Там надо зайти в Kompute Engine->Образы и там на основе вашего загруженного стораджа сделать образ и тогда всё взлетает. А так у вас всё замечательно)

        1. Юрий Грибов Автор записи

          Ну вот же описание создания образа, практически начало поста:

          mkdir chr
          cd chr
          wget https://download.mikrotik.com/routeros/6.44.6/chr-6.44.6.img.zip
          unzip chr-6.44.6.img.zip
          truncate –size=1G chr-6.44.6.img
          mv chr-6.44.6.img disk.raw
          tar -Sczf chr-6.44.6.img.tar.gz disk.raw

          Или мы о чём то разном?

  3. Anatoliy

    Спасибо , сделал по инструкции все заработало.

    А вот еще статеечку по настройке VPN на RouterOS в GoogleCloud дописали с белым внешним IP ?

    1. Юрий Грибов Автор записи

      Всегда пожалуйста, рад что написанное кому то помогает!
      Не дописал, хотя VPN юзаю активно )

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *