MikroTik: настройка беспроводного моста точка-точка (PtP) и точка-многоточка (PtMP)

MikroTik SXT SA5 ac

Преамбула

В результате падения дерева была оборвана линия связи между заводскими цехами. В результате аварии без связи остался один цех (интернет, IP-телефония) и пропал доступ к нескольким камерам видеонаблюдения.

В качестве временного решения был поднят радиомост из того что было под рукой (TP-Link). Одновременно были заказаны микротики.

И вот они пришли, приступаем к настройке.

Настройка

Подопытные: MikroTik SXT SA5 ac (RBSXTG-5HPacD-SA), актуальная версия RouterOS на момент написания статьи 6.45.9 (long-term).

В первую очередь обновляем версию RouterOS до актуальной и сбрасываем все настройки. Как это делать описывать не буду, если кто не знает можете прочитать в одной и моих предыдущих записей.

Так же не буду описывать как сменить пароль администратора и тому подобные базовые вещи, приступим сразу к настройке радиомоста и начнём с точки, которая будет выполнять функции базовой станции (BS).

Все настройки рекомендую производить в своём кабинете и на место уже устанавливать полностью настроенными.

Настройка базовой станции

  • Создаём бридж и добавляем в него все интерфейсы (ether1 и wlan1)
/interface bridge
add name=bridge1
/interface bridge port
add bridge=bridge1 interface=wlan1
add bridge=bridge1 interface=ether1
  • Присваиваем бриджу IP-адрес
MikroTik: настройка беспроводного моста точка-точка (PtP) и точка-многоточка (PtMP)
Присваиваем IP-адрес
/ip address
add address=192.168.88.116/24 interface=bridge1 network=192.168.88.0
  • Переходим в настройки Wireless и создаём Security Profiles
MikroTik: настройка беспроводного моста точка-точка (PtP) и точка-многоточка (PtMP)
Security Profiles
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa2-psk disable-pmkid=yes eap-methods="" management-protection=allowed mode=dynamic-keys \
    name=xxxxx supplicant-identity="" wpa2-pre-shared-key=QqAaZzWwSsXx
  • Настраиваем интерфейс wlan1

Изначально Wireless Protocol я настраиваю как nv2 nstreme 802.11, затем после установки на месте я на базовой станции переключаюсь между nv2 и 802.11 и смотрю какой из них лучше себя ведёт в плане скорости и устойчивости. Если 802.11 показывает себя быстрее, то оставляю его и наблюдаю в течении некоторого времени на предмет срабатывания DFS (Dynamic Frequency Selection). Если в логах появляется запись вроде такой

wlan1: radar detected on 5260000

то переключаю BS на nv2 и забываю об этой проблеме.

Ещё один момент на который стоит обратить внимание. При работе по протоколу nv2, Security Profiles не используется. На вкладке с настройкой NV2 устанавливается свой PSK.

Antenna Gain берём из документации на устройство на сайте MikroTik. Вообще данный параметр указывает на сколько нужно понизить выдаваемую мощность передатчика, которая компенсируется коэффициентом усиления антенны что бы не нарушать законодательство страны.

Band, Channel Width и Frequency выбираем по радиообстановке на месте.

Mode для базовой станции устанавливаем ap bridge.

/interface wireless
set [ find default-name=wlan1 ] adaptive-noise-immunity=ap-and-client-mode antenna-gain=16 band=5ghz-onlyac \
    channel-width=20/40/80mhz-Ceee disabled=no frequency=5260 hw-protection-mode=rts-cts installation=outdoor \
    mode=ap-bridge multicast-helper=full nv2-cell-radius=10 nv2-preshared-key=xxxxx nv2-qos=\
    frame-priority nv2-security=enabled security-profile=xxxxx ssid=XXXXX wireless-protocol=nv2-nstreme-802.11 \
    wmm-support=enabled wps-mode=disabled

Настройка клиентской точки

Настройка клиентской точки по сути ничем не отличается от настройки базовой станции кроме двух пунктов.

В настройках wlan1 Mode выбираем station bridge и Adaptive Noise Immunity выбираем client mode.

/interface wireless
set [ find default-name=wlan1 ] adaptive-noise-immunity=client-mode antenna-gain=16 band=5ghz-onlyac \
    channel-width=20/40/80mhz-Ceee disabled=no frequency=5260 hw-protection-mode=rts-cts installation=outdoor \
    mode=station-bridge multicast-helper=full nv2-preshared-key=xxxxxxxx nv2-security=enabled \
    security-profile=xxxxx ssid=XXXXX wireless-protocol=nv2-nstreme-802.11 wmm-support=enabled

Отличия точка-точка (P2P) и точка-многоточка (P2MP)

С точки зрения настроек отличие только одно – на базовой станции Mode устанавливается или bridge или ap bridge.

В первом случае работаем точка-точка, во втором точка-многоточка.

Так же если на точке выполняющей роль базовой станции установлена лицензия level 3, то работа в режиме ap bridge невозможна. Ну или работать будет по принципу кто первый сел, тот и съел )) Хотя последнее не проверял, у меня нет точек с такой лицензией.

Выбор устройства для беспроводного моста

Собственно то, с чего следовало начать данную статью ))

Есть официальные рекомендации от MikroTik по выбору устройств в зависимости от расстояния и режима работы, остаётся только привести их здесь и следовать рекомендациям ))

Установка на месте

В моём конкретном случае антенны никак не юстировал, устанавливал на “глазок”. Небольшое расстояние плюс секторная антенна на 90 градусов позволяли это сделать. А вообще есть встроенная утилита для настройки направления антенны. Для её использования на базовой станции устанавливается Mode alignment only и на клиентской станции запускается утилита Align из меню настроек wlan.

Так как сам ею не пользовался, а переписывать чужое не в моих правилах, то и описание пока опущу. Как только воспользуюсь так сразу восполню данный пробел.

А пока просто приведу скриншот вкладки статус подключения.

MikroTik: настройка беспроводного моста точка-точка (PtP) и точка-многоточка (PtMP)
Оцените данную запись
 [Всего голосов: 1 - Общая оценка: 5]

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *